Help, WSJT-X and Quisk on RPi3

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Help, WSJT-X and Quisk on RPi3

Takajin
I have a problem  “not to send audio data from WSJT-X to Quisk”.
My setup is as follows
  1.Softrock Ensemble RXTX
  2.USB Soundcard:StartTech7.1
  3.Raspberry Pi 3 B / OS: LINUX Raspbian Jessie 4.4.11-v7
  4.Quisk-4.1.1
  5.WSJT-X  v1.7.0-rc1

I am using ALSA loopback by the information of “Quisk document”.
 1. Activate loopback
   sudo modprobe snd-aloop
 2.Add for quisk_conf.py
   digital_input_name=”hw:loopback,0”
   digital_output_name=digital_input_name
 3.WSJT-X setting “Audio”
   Soundcard
      Input  : "plughw:CARD=Loopback,DEV=1”
      output: "plughw:CARD=Loopback,DEV=1”
JT-65/JT-9 ,.. signal of WSJT-X is well received, but transmit date is not
transferred to Quisk. ("Mode" of Quisk is "DGT-U")
I can not observe transmit data stream(when transmitting) from WSJT-X
to Quisk.
Data flow by the screen of Quisk “Status” is as follows.

     Device                              Name          Sample rate  Latency   Errors
    --------------------------------------------------------------------------------
     Capture radio samples        hw:0                 48000     (vary)      …
     Capture digital Tx samples  hw:Loopback,0  48000    0(fixed!)     …
     Play radio sound                hw:1                 48000     (vary)      …
     Play digital mode sound      hw:Loopback,0  48000     (vary)      …
   --------------------------------------------------------------------------------
  (note) for my case, hw:0 is USB soundcard, hw:1 is on boad bcm2835 )

"Latency" of  “Capture digital Tx samples” is not changed  when transmitting.

Thanks, Taka/JA1TLH

Reply | Threaded
Open this post in threaded view
|

Re: Help, WSJT-X and Quisk on RPi3

kc7noa
This post was updated on .
I have the same problem with alsa ....

But when using pulseaudio i can get Tx audio from wsjtx to quisk ...

There needs to be something that a person can use to verify audio streams .. i wish for alsa.

Keep trying,

 ... snd-aloop is saposed to be a alsa device ...

I wonder if trying to use aplay to play a short audio file to the snd-aloop and see if quisk reacts ... if your using VOX,

Sounds like aloop is working for Rx of audio from quisk to wsjtx for you ... i have not been able to do that with alsa yet ...

Perhapse use this aplay example to test the snd-aloop paths ...

http://www.alsa-project.org/main/index.php/Matrix:Module-aloop
Reply | Threaded
Open this post in threaded view
|

Re: Help, WSJT-X and Quisk on RPi3

kc7noa
I tried to record from the Loopback ....i cant seem to record anything from it ....

Iv given enough time to this ,,.... im going to add another soundcard and hard wire it to the microphone/speaker of quisk
Reply | Threaded
Open this post in threaded view
|

Re: Help, WSJT-X and Quisk on RPi3

Takajin
In reply to this post by kc7noa
to KC7NOA

Thanks for your info.

>I have the same problem with alsa ....
>But when using pulseaudio i can get Tx audio from wsjtx to quisk ...

You succeeded transmit from WSJT-X to Quisk!  Great!
Please let me know your setup when using pulseaudio.
 1. conf file of Quisk
 2. WSJT-X
    “Audio” setting
       Soundcard
         Input  : ?
         output:  ?

Taka/JA1TLH

 
Reply | Threaded
Open this post in threaded view
|

Re: Help, WSJT-X and Quisk on RPi3

kc7noa
Having the same problem with Alsa as i do with Pulseaudio ... means that you can get it to Tx ... but the problem is that there is no I/Q balance ... wsjtx was setup to use radio input and quisk was set to "monitor" of that same device ...

there needs to be some trouble shooting done with snd-aloop .... it only half works ...(Rx)
Reply | Threaded
Open this post in threaded view
|

Re: Help, WSJT-X and Quisk on RPi3

Takajin
to kc7noa

>... means that you can get it to Tx ... but the problem is that there is no I/Q balance
> ... wsjtx was setup to use radio input and quisk was set to "monitor" of that same device ...

It's regrettable that there is no I/Q balance!  I have to wait new SDR software "Power SDR(Linux
version)".

DE JA1TLH