Latency

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Latency

Nick
quisk-4.1.2

What do the Latency readings on the Status tab indicate?

What are the units they are reported in?

73

Nick
G3VNC
Reply | Threaded
Open this post in threaded view
|

Re: Latency

kc7noa
I think its for each sound device that been set ....
and i think its in milliseconds...

Reply | Threaded
Open this post in threaded view
|

Re: Latency

Nick
kc7noa wrote
I think its for each sound device that been set ....
and i think its in milliseconds...
Yes, it is per sound device.  But I am not convinced that it is milliseconds.

With Radio/Sound/Play Latency set to 50 ms I get this



There is nothing like 9 seconds latency on the RX IQ capture from the softrock.

Neither is there anything like 1.8 seconds on the TX IQ playback to the softrock.

I cannot find any reference to this in any documentation.  I will look at the source code.

73

Nick
G3VNC
 
Reply | Threaded
Open this post in threaded view
|

Re: Latency

kc7noa
what do you have the attempted latency set to ?
100mS ?
Reply | Threaded
Open this post in threaded view
|

Re: Latency

kc7noa
Perhapse you could also make a brief write up on how to use jack ....
Reply | Threaded
Open this post in threaded view
|

Re: Latency

Nick
In reply to this post by kc7noa
50ms - see previous post at 11:17.
Reply | Threaded
Open this post in threaded view
|

Re: Latency

Nick
In reply to this post by kc7noa
kc7noa wrote
Perhapse you could also make a brief write up on how to use jack ....
See my previous post "Quisk CW on Softrock Ensemble RXTX with a single Delta 44 sound card".
Reply | Threaded
Open this post in threaded view
|

Re: Latency

Nick
In reply to this post by Nick
Nick wrote
I cannot find any reference to this in any documentation.  I will look at the source code.
It seems that the Latency figures on the Status tab are in samples.

If the sample rate is 48000 samples per second that is 20.83 us/sample.

So a reported latency of 1400 is about 29 ms.

Can anyone confirm this?

73

Nick
G3VNC