quisk ImportError: No module named wxversion

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

quisk ImportError: No module named wxversion

DL6SXX
Does Quisk 3.6.18 have a problem with ubuntu 14.04? I get the message "ImportError: No module named wxversion". I installed all packages concerning this (python-wxversion). I have installed also python 2.7. on my ubuntu 14.04.  ubuntu 14.04 had python 3.x.
I read both python versions are not compatible. I read also that quisk was written in python 2.7.
Do you have an idea to run quisk on ubuntu 14.04?

It works good with open suse 13.1. It has only python 2.7 installed.


Reply | Threaded
Open this post in threaded view
|

Re: quisk ImportError: No module named wxversion

ahlstromjc
Administrator
Hello,

I am running Ubuntu 14.04 LTS, and there is no problem.  It came with both Python 2.7 and Python 3.  From a terminal, python starts Python 2.7, and python3 starts Python 3.4.0.

The command "python quisk.py" should run Quisk with no problems.  If wxversion is missing, then you probably installed it for python 3, but not for Python 2.7.

From a terminal, start Python by entering "python", and see that Python 2.7 starts.  Then enter "import wx" and "import wxversion" and see what happens.

Jim
N2ADR
Reply | Threaded
Open this post in threaded view
|

Re: quisk ImportError: No module named wxversion

DL6SXX
Hello Jim, fine! It is an easy check of availability of modules. One package wasn't installed correctly. Now quisk runs.
73 de
Helge